0

Dac+DSP - No ALSA controls

I have tried my best to figure this out but have hit a very large brick wall.

Dac+DSP - on CompanionPi image and the default latest Raspberry Pi OS Lite

I'm just using it to take audio in on the optical in and pass that straight to the analogue out. The aim being to have volume control using alsamixer.

I had this fully working at easter - but due to me killing the SD card with no backups I'm now having to rebuild it...

No matter that I do I can't get any control to turn up in ALSA mixer. "This device has no controls"

I have followed all of the guides - tried the dtoverlay of dac and dacplusdsp - nothing I do makes any changes.

If I load up the same hardware with a hifiberryos card (created back in easter) - the controls turn up in alsamixer when I ssh in.

So I am reasonably sure that I am missing something in the OS

The one odd thing is that amixer just returns a blank command line unless I run amixer -h - which makes following the more detailed fault finding guides very difficult ....

I have 10 of these boards ready to roll out to the lecture rooms so any help would be greatly received !!

4 comments

Please sign in to leave a comment.