Dac+ & Digi+ software volume control doesn't work on new builds

Using V2 Raspberry pi with Dac+ and Raspberry pi with Digi+.
Bullseye 32K Lite operating system.
mpd music player
Pete Manchester's MediaPlayer (To gain Open Home Functionality)

Until this last two months, the software volume control function in mpd's alsa settings worked well for both HiFiberry output cards.
The only extra config required to make it work was in /etc/mpd.conf where these lines were needed:

group "audio”
bind_to_address "any"

audio_output {
type "alsa"
name "My ALSA Device"
mixer_type "software"

And that was it, the volume control just worked and indeed because I have old builds saved, they still do.
However, all careful attempts to build a system with software volume control now fail, it just simply no longer works.

It's very odd, I can find no clue anywhere as to why and even the version of mpd (0.22.6) is the same on the older builds that work.

In order to get HiFiBerry cards to play music I also:

In /boot/config.txt stop other audio outputs with lines changed to:
## dtparam=audio=on 

I then add either:
dtoverlay=hifiberry-dacplus OR dtoverlay=hifiberry-digi

Lastly I add the recommended file /etc/asond.conf

If anyone has any suggestions how I can find and fix this I would be very grateful.

Thank you.




Please sign in to leave a comment.