0

No sound with Amp100 & DSP

Hey!

I have a Raspberry Pi 4, an Amp100 and a DSP add-on board with a 30V power supply via the screw terminal. Without the DSP, the amp works as expected. With the DSP, there is no sound. I only hear a faint popping sound when starting playback.

I also tried to replace the DSP board with one that I use in another setup but that did not help.

Any idea on how to fix it? Thanks!

Florian

 

More details:

- HiFiBerryOS 20220228

- DSP program 13

- tried playback via Airplay and `play -c2 -n synth sine 1000`

- tried DSP profiles dspdac-noautomute.xml and dacdsp-default.xml

# dsptoolkit get-volume
Volume: 1.0002 / 100% / 0db

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 [HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# cat /boot/config.txt
# Please note that this is only a sample, we recommend you to change it to fit
# your needs.
# You should override this file using a post-build script.
# See http://buildroot.org/manual.html#rootfs-custom
# and http://elinux.org/RPiconfig for a description of config.txt syntax

# We always use the same names, the real used variant is selected by
# BR2_PACKAGE_RPI_FIRMWARE_{DEFAULT,X,CD} choice
start_file=start.elf
fixup_file=fixup.dat

kernel=zImage

# To use an external initramfs file
#initramfs rootfs.cpio.gz

# Disable overscan assuming the display supports displaying the full resolution
# If the text shown on the screen disappears off the edge, comment this out
disable_overscan=1

# How much memory in MB to assign to the GPU on Pi models having
# 256, 512 or 1024 MB total memory
gpu_mem_256=100
gpu_mem_512=100
gpu_mem_1024=100
# Enable I2C and SPI
dtparam=i2c=on
dtparam=spi=on
dtoverlay=i2c-gpio,i2c_gpio_sda=0,i2c_gpio_scl=1
dtoverlay=vc4-fkms-v3d,audio=off
force_eeprom_read=0
dtoverlay=hifiberry-amp100,automute

# cat /etc/asound.conf
#
# asound.conf for exclusive audio mode
#
defaults.pcm.rate_converter "samplerate"

defaults.pcm.card 0
defaults.ctl.card 0

pcm.hifiberry {
  type hw
  card 0
  device 0
}
pcm.ttable {
 type route
 #ttable_config:stereo 0
 ttable.0.0 1
 ttable.1.1 1
 ttable.0.1 0
 ttable.1.0 0
 slave.pcm "hifiberry"
}
pcm.softvol {
  type softvol
  slave.pcm "ttable"
  control {
    name "Softvol"
    card 0
  }
  min_dB -90.2
  max_dB 0.0
}
ctl.equal {
  type equal;
}
pcm.equal {
  type equal;
  slave.pcm "plug:softvol";
}
pcm.!default { type plug; slave.pcm "softvol" } # SOFTVOL

8 comments

Please sign in to leave a comment.