0

Digi Pro 2 - overlay config line being overwritten

I posted before about issues getting my Digi Pro 2 to work

I have made some "progress" but still have issues.

I am running HifiBerry OS.

When I installed the Digi2 Pro hat the config.txt file was updated but the overlay it configured was

dtoverlay=hifiberry-dac

I edited the config.txt file and commented out this line and inserted

dtoverlay=hifiberry-digi-pro

as per the online documentation, but when I reboot this gets overwritten with the DAC overlay again

I have added the line to disable the EEPROM

force_eeprom_read=0

My config.txt file now looks like this

# Please note that this is only a sample, we recommend you to change it to fit
# your needs.
# You should override this file using a post-build script.
# See http://buildroot.org/manual.html#rootfs-custom
# and http://elinux.org/RPiconfig for a description of config.txt syntax

# We always use the same names, the real used variant is selected by
# BR2_PACKAGE_RPI_FIRMWARE_{DEFAULT,X,CD} choice
start_file=start.elf
fixup_file=fixup.dat

kernel=zImage

# To use an external initramfs file
#initramfs rootfs.cpio.gz

# Disable overscan assuming the display supports displaying the full resolution
# If the text shown on the screen disappears off the edge, comment this out
disable_overscan=1

force_eeprom_read=0

# How much memory in MB to assign to the GPU on Pi models having
# 256, 512 or 1024 MB total memory
gpu_mem_256=100
gpu_mem_512=100
gpu_mem_1024=100
# Enable I2C and SPI
dtparam=i2c=on
dtparam=spi=on
dtoverlay=i2c-gpio,i2c_gpio_sda=0,i2c_gpio_scl=1
dtoverlay=vc4-fkms-v3d,audio=off
# dtoverlay=hifiberry-dac
dtoverlay=hifiberry-dac

and the results of aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Can I get further advice 

Thanks

John

3 comments

Please sign in to leave a comment.