Digi 2 Pro still no audio!

Please help the following issue persists. Digi 2 Pro no audio coax or opt.Any suggestion. Testing with Pi 4. Opt lights up and OS appears to stream airplay. Thx Test tone: # play -n synth sine 1000 play WARN alsa: can't encode 0-bit Unknown or not applicable File Size: 0 Encoding: n/a Channels: 1 @ 32-bit Samplerate: 48000Hz Replaygain: off Duration: unknown In:0.00% 00:00:46.93 [00:00:00.00] Out:2.25M [!=====|= Aplay -l appears to be good. Driver is correct. **** List of PLAYBACK Hardware Devices **** card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 [HiFiBerry Digi+ Pro HiFi wm8804-spdif-0] Subdevices: 1/1 Subdevice #0: subdevice #0 Config txt. I added correct dtoverlay but after reboot is changed it to blocked. Please note that this is only a sample, we recommend you to change it to fit # your needs. # You should override this file using a post-build script. # See http://buildroot.org/manual.html#rootfs-custom # and http://elinux.org/RPiconfig for a description of config.txt syntax # We always use the same names, the real used variant is selected by # BR2_PACKAGE_RPI_FIRMWARE_{DEFAULT,X,CD} choice start_file=start.elf fixup_file=fixup.dat kernel=zImage # To use an external initramfs file #initramfs rootfs.cpio.gz # Disable overscan assuming the display supports displaying the full resolution # If the text shown on the screen disappears off the edge, comment this out disable_overscan=1 # How much memory in MB to assign to the GPU on Pi models having # 256, 512 or 1024 MB total memory gpu_mem_256=100 gpu_mem_512=100 gpu_mem_1024=100 # Enable I2C and SPI dtparam=i2c=on dtparam=spi=on dtoverlay=i2c-gpio,i2c_gpio_sda=0,i2c_gpio_scl=1 dtoverlay=vc4-fkms-v3d,audio=off dtoverlay=hifiberry-blocked


Please sign in to leave a comment.