New HifiBerry OS installation not working

I have three HifiBerry OS devices that were all working fine. for reasons that are not relevant here I switched cards between them... now I am left with one card that will work on any of the three devices and two cards that ar not working on any device. I re-flashed several times to both these cards, downloaded the lastest HB OS, latest Balena Etcher, tried both on windows and mac and same thing - when I insert the card and start the device it's like there's no card inserted (the red led turns on but nothing on the HDMI connected screen and no lights on the ethernet port. of course then the devices are not visible on the network at all).

The one SD card I have that works, will work properly in any device... so the devices are fine. Also the ethernet cable is good since it works with the one device that works fine. 

The devices are RPi4 with XLR dac cards and one with HifiBerry Amp2. 

So the obvious thought is that both cards are somehow defective (even though they worked and are seen correctly under windows or mac). 

To be very clear - the one card that works was flashed about two years ago, the two that don't were flashed now. 

I will buy a new card tomorrow to try that but is there anything that I may be missing? It's quite strange that both cards could be defective at the same time. 

Thanks for any suggestions


Please sign in to leave a comment.