0

RASPBERRY PI 3 B+ and DAC+ STANDARD = NO SOUND

Hi everyone,

 

I'm facing a problem with my new sound DAC+ standard.

I did every step mentionned in the configuration topic :

- add "dtoverlay=hifiberry-dacplus" in /boot/config.txt

- remove "dtparam=audio=on"

- configuring alsa by creating /etc/asound.conf file with the appropriate content

- update the Linux kernel

Then reboot the pi, a green led appears on the sound card when pi is starting.

i tried with sox and a 1000 sine wave, mplayer and wav file, and vlc, at each time the greens led appears, then keep lighting until i stop the process, but no sound...

The card is connected to a well-working amplifier via RCA connections.

Everything works fine with AV jack and HDMI outputs.

Here is my config :

Raspberry Pi 3B+ with last version of Raspberry Pi Desktop and Debian

DAC+ standard

/boot/config.txt

[all]
dtoverlay=hifiberry-dacplus

aplay -l

pi@raspberrypi:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 [HiFiBerry DAC+ HiFi pcm512x-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

sox

pi@raspberrypi:~ $ play -n synth sine 1000
\play WARN alsa: can't encode 0-bit Unknown or not applicable

File Size: 0
Encoding: n/a
Channels: 1 @ 32-bit
Samplerate: 48000Hz
Replaygain: off
Duration: unknown

In:0.00% 00:00:04:88 [00:00:00:00] Out:90.1k.....

amixer

pi@raspberrypi:~ $ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]
 
I'm afraid this config for amixer is not appropriate, am I right?
I tried with the configuration line" amixer cset numid=3 1" but nothing changes.
Why dac+ still not appears as the default card ? What is pulse audio card ?
Or is it a problem with my asound.conf file ? He's located in /etc.
 
Also, i didn't see anything related to the sound card in dmesg output.
But with "sudo vcdbg log msg" I've got "loaded overlay 'hifiberry-dacplus'"
 
At the bottom, there are some screeshots of alsamixer
 
I even tried to erase my Debian config and try with a fresh and clean new one.
Can anyone help me with this? I'm totally stuck unfortunately...
 

1 comment

Please sign in to leave a comment.