0

Digi+ I/O to Darkice.

Hi all.

I have a Raspberry Pi 4 Model B with a fresh install of Raspberry Pi OS.

I installed and configured Darkice with a USB audio adapter to accept an audio input and stream it to an IceCast2 server.

I have since replaced the USB audio adapter with a HiFiBerry Digi + i/o. I adjust the boot/config.txt with the following information:

I # out the dtparm=audio=on

and added

dtparam=i2c_arm=on

dtparam=i2S=on

dtoverlay=hifiberry-digi

dtparam=audio=on

enable_uart=0

gpu_mem=124

dtdebug=1

dtparam=spi=on

I then adjusted the darkice.cfg to point to the correct hardware by adjusting device=plughw:2,0

The audio is now coming from the optical input on the HiFiBerry board but the sound is fast, then it stops, then starts again running fast.

I'm guessing it's the sampling rate, but how do I adjust it? The rate options in Darkice don't seem to make a difference.

Regards,

Nigel.

 

 

1 comment

Please sign in to leave a comment.