Several problems with HIFIBerryOS on pi 4

Downloaded the latest OS (as of 1.14.2020) and tried to fire up HIFIBerry.  I'm using DAC+ RCA version and a pi4.

- Although I could input a password for wifi, it didn't actually connect until a reboot.

- Says Spotify connect is running, but nothing showed up on my Spotify app (android) on my phone.  After another reboot, it did show up but "could not connect" to the device. I tried turning Spotify connect on within the pi, both times I tried it just hung forcing a manual reboot.

- Although instructions say to connect to the pi's wifi network for configuration, at no point did the pi broadcast a wifi SSID. 

- Tried to rename the HIFIBerry as something other than HIFIBerry and it didn't rename.

I tried using hardwired ethernet for all testing as well and not luck.  The configuration work I am doing has been via keyboard, mouse and monitor on the pi itself.

I've been running an earlier version of HIFIBerry OS on a pi 3 almost continuously for about 9 months now, with no issues.


Please sign in to leave a comment.