0

Raspotify Configuration

Hello,

I want to begin by thanking those (particularly Daniel) who have helped me on this website. 

In order to solve this issue, I think I need to provide background. I was running Raspberry Pi OS with Kodi, Retropie, and VLC, and would run Raspotify from my phone, all outputting audio through my DAC2 HD. I downloaded script for a latching power switch, which caused my DAC2 HD to stop working.

I have since uninstalled the script for the latching power switch, and I have been able to get audio through the DAC2 HD when using Kodi, Retropie, and VLC. However, I have not been able to get Raspotify to connect. On Spotify on my phone, I am able to see Raspotify on my list of devices to stream to, but the option is grayed out with a message saying, "Can't play this right now."

For reference, here is my Raspotify config file:

# /etc/default/raspotify -- Arguments/configuration for librespot

# Device name on Spotify Connect
DEVICE_NAME="raspotify"

# Bitrate, one of 96 (low quality), 160 (default quality), or 320 (high quality)
BITRATE="320"

# Additional command line arguments for librespot can be set below.
# See `librespot -h` for more info. Make sure whatever arguments you specify
# aren't already covered by other variables in this file. (See the daemon's
# config at `/lib/systemd/system/raspotify.service` for more technical details.)
#
# To make your device visible on Spotify Connect across the Internet add your
# username and password which can be set via "Set device password", on your
# account settings, use `--username` and `--password`.
#
# To choose a different output device (ie a USB audio dongle or HDMI audio out),
# use `--device` with something like `--device hw:0,1`. Your mileage may vary.
#
OPTIONS="--username <haha> --password <nottelling>"

--device snd_rpi_hifiberry_dacplushd # Uncomment to use a cache for downloaded audio files. Cache is disabled by # default. It's best to leave this as-is if you want to use it, since # permissions are properly set on the directory `/var/cache/raspotify'. #CACHE_ARGS="--cache /var/cache/raspotify" # By default, the volume normalization is enabled, add alternative volume # arguments here if you'd like, but these should be fine. #VOLUME_ARGS="--enable-volume-normalisation --linear-volume --initial-volume=100" # Backend could be set to pipe here, but it's for very advanced use cases of # librespot, so you shouldn't need to change this under normal circumstances. #BACKEND_ARGS="--backend alsa" # The displayed device type in Spotify clients. # Can be "unknown", "computer", "tablet", "smartphone", "speaker", "tv", # "avr" (Audio/Video Receiver), "stb" (Set-Top Box), and "audiodongle". #DEVICE_TYPE="speaker"

I am rather annoyed with myself that I had this properly configured before, but was not wise enough to make a copy before trying to add that latching switch, which I had to abandon anyway.

If any more information is required to help me through this, I will gladly provide.

Thanks again for all the help.

0 comments

Please sign in to leave a comment.