0

HifiBerry DAC+

I have configured the RPI 4 according the link of Configuring Linux 4.x or higher to install and configure the HifiBerry DAC+.

The HifiBerry DAC+ card is mostly recognized by the RPI after boot but it is sometimes not. 

When it is recognized, I see in the messages log:

Sep 2 19:17:23 raspberrypi kernel: [ 5.623908] snd-rpi-hifiberry-dacplus soc:sound: pcm512x-hifi <-> fe203000.i2s mapping ok
Sep 2 19:17:27 raspberrypi kernel: [ 11.428646] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:27 raspberrypi kernel: [ 11.514190] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:27 raspberrypi kernel: [ 11.520322] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.197463] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.217971] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.382368] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.389541] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.397428] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.414704] pcm512x 1-004d: No SCLK, using BCLK: -2
Sep 2 19:17:28 raspberrypi kernel: [ 12.427305] pcm512x 1-004d: No SCLK, using BCLK: -2

 

When it is not recognized, there are no loggings visible regarding the hifiberry and pcm512x chip.

How can I be sure that the DAC+ is always loaded/working?

16 comments

Please sign in to leave a comment.