0

AMP2 not working on a system I'm working on

Hi,

I am trying to use an AMP2 to play music on a rpi I'm working on. After following the configuration instruction, the rpi recognize the AMP2 but the system still shows "No volume control on this device"

I looked through the forum. Most of the discussion seems to suggest my SD card is corrupted. I did get a new sd card, and it works. But transferring all my code is something I'd really like to avoid doing. So I'd like to ask and confirm my issue. Is there something wrong I did to cause this issue? 

 

Here are the information I got:

amm@raspberrypi:~ $ aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 [HiFiBerry DAC+ HiFi pcm512x-hifi-0]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

 

amm@raspberrypi:~ $ amixer

amixer: Mixer attach default error: Invalid argument

 

Here is the config.txt:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
# hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835) Disabled for Hifiberry config
# dtparam=audio=on

#this following line is added for hifiberry config to load the correct device tree file
dtoverlay=hifiberry-dacplus
force_eeprom_read=0

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
dtoverlay=vc4-fkms-v3d
enable_uart=1

dtoverlay=disable-bt

# Debug

dtdebug=1

4 comments

Please sign in to leave a comment.