0

DAC+ pi4 dtoverlay=hifiberry-dacplus does not load

Pi 4, new installation

DAC+ board (with HW 2.6)

Following the guide here

https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/

Does not load correct dtoverlay=hifiberry-dacplus.

Interestingly dtoverlay-hifiberry-dac loads

With and aplay -l that gives:

card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

However,

Unable to even play a test wav file.

Weid - I assumed that the correct dtoverlay should be the hifiberry-dacplus.

If I us the same DAC+ board with a Pi 3 and use volumio (as a test)

All is well. Therefore I do not think that the DAC+ is faulty.

I am going around in circles.

I've also tried with 

force_eeprom_read=0
in config.txt

What on Earth am I doing wrong?

Summary:

Linux raspberrypi 5.4.51-v7l+ #1333 SMP Mon Aug 10 16:51:40 BST 2020 armv7l GNU/Linux

**


asound.conf

pcm.!default { type hw card 0 } ctl.!default { type hw card 0 }


**

For MPD, just tried several ideas and last was:

audio_output {

type "alsa"

name "My ALSA Device"

device "hw:0,0" # optional

mixer_type      "hardware"      # optional

# mixer_device "default" # optional

mixer_control "Digital" # optional

# mixer_index "0" # optional

}

 

7 comments

Please sign in to leave a comment.