0

Lost modules after kernel upgrade on Raspbian

Hello,

I have been using a hifiberry dac+ on a raspberry 3 for some time now. I just upgraded the rasbian system, and now it can't seem to find the modules at boot time.

root@raspberrypi:/home/pi# uname -a
Linux raspberrypi 5.4.51-v7+ #1326 SMP Fri Jul 17 10:45:25 BST 2020 armv7l GNU/Linux

root@raspberrypi:/home/pi# cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

snd_soc_bcm2708
bcm2708_dmaengine
snd_soc_pcm512x
snd_soc_hifiberry_dacplus

root@raspberrypi:/home/pi# aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: b1 [bcm2835 HDMI 1], périphérique 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Sous-périphériques: 4/4
Sous-périphérique #0: subdevice #0
Sous-périphérique #1: subdevice #1
Sous-périphérique #2: subdevice #2
Sous-périphérique #3: subdevice #3
carte 1: Headphones [bcm2835 Headphones], périphérique 0: bcm2835 Headphones [bcm2835 Headphones]
Sous-périphériques: 4/4
Sous-périphérique #0: subdevice #0
Sous-périphérique #1: subdevice #1
Sous-périphérique #2: subdevice #2
Sous-périphérique #3: subdevice #3
root@raspberrypi:/home/pi#

root@raspberrypi:/home/pi# modprobe snd_soc_bcm2708
modprobe: FATAL: Module snd_soc_bcm2708 not found in directory /lib/modules/5.4.51-v7+

Any idea ?

When I halt my system, i have a strange error message "under-voltage detected"  (plus, there's a picture of a lightning in the top right corner of the screen) and it hangs...

 

 

 

 

 

16 comments

Please sign in to leave a comment.