0

DAC+ DSP arecord not working

Hi,

I'm trying to record audio that is created on my raspberry via librespot to distribute it further. The analog output works flawless, but arecord records nothing.

I'm running raspbian on a raspberry 3+. All updates applied.

uname -a:

Linux xxx 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux

my boot/config:

dtoverlay=hifiberry-dacplusdsp
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
dtoverlay=disable-wifi
dtparam=spi=on

installed profile:

https://raw.githubusercontent.com/hifiberry/hifiberry-os/master/buildroot/package/dspprofiles/dspdac-10.xml

aplay -L output:
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndrpihifiberry
snd_rpi_hifiberrydacplusdsp_sou, Hifiberry DAC+DSP SoundCard HiFi dacplusdsp-codec-0
Default Audio Device
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberrydacplusdsp_sou, Hifiberry DAC+DSP SoundCard HiFi dacplusdsp-codec-0
Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberrydacplusdsp_sou, Hifiberry DAC+DSP SoundCard HiFi dacplusdsp-codec-0
Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberrydacplusdsp_sou, Hifiberry DAC+DSP SoundCard HiFi dacplusdsp-codec-0
Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberrydacplusdsp_sou, Hifiberry DAC+DSP SoundCard HiFi dacplusdsp-codec-0
Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberrydacplusdsp_sou, Hifiberry DAC+DSP SoundCard HiFi dacplusdsp-codec-0
Hardware device with all software conversions

I tried playing to hw, plughw and recording from hw and dsnoop. Nothing works. For me it seems like an issue with the dspprofile or the driver.

Is this expected to work?

 

kind regards,

Gabriel

3 comments

Please sign in to leave a comment.