0

AMP2 Multisource configuration not working

Hi

I have an AMP2.
Set up the latest version of Raspbian Lite version.
I have installed shairport-sync.

Technical infos about the setup
======================================================
uname -a
Linux Konyha 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux
======================================================
aplay -lL
null
Discard all samples (playback) or generate zero samples (capture)
default
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0
Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0
Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0
Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0
Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0
Hardware device with all software conversions
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 [HiFiBerry DAC+ HiFi pcm512x-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0
======================================================
cat /etc/asound.conf
pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}
======================================================
sudo -u shairport-sync id
uid=999(shairport-sync) gid=995(shairport-sync) groups=995(shairport-sync),29(audio)
======================================================
tail /boot/config.txt
[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

dtoverlay=hifiberry-dacplus
dtoverlay=i2s-mmap
======================================================

Result: shairport is running well, sound is OK.

Great, i want to achive 2 more goals:
- have an equalizer to fine tune bass and treble
- set up a dmix with alsa, to be able to run 2 application sources

Ok, lets see what we got here:
https://support.hifiberry.com/hc/en-us/articles/207397665-Mixing-different-audio-sources

New asound.conf
======================================================
cat /etc/asound.conf
pcm.hifiberry {
type hw card 0
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hifiberry"
channels 2
}
}

ctl.dmixer {
type hw
card 0
}
======================================================
sudo service shairport-sync restart
======================================================

Result: shairport is running well, but there is NO sound :(

No other application using the sound device is running.

Please help me to fix it

0 comments

Please sign in to leave a comment.