0

Digi+ playback speed too fast

Dear Hifiberry users,

After a quick setup, the output of the Digi+ Standard plugged to my DAC over a Toslink cable, I noticed a weirdly fast playback of my music.

I have installed the Digi+ standard on a RPi3 - Raspbian buster. Then I set it up as below :

/boot/config.txt :

# dtparam=audio=on
dtoverlay=hifiberry-digi

/etc/asound.conf :

pcm.!default {
 type hw
 card 0
}

ctl.!default {
 type hw
 card 0
}

The DAC is a hifi amp with an optical input module which is specified as standard 2 chanels linear PCM. But I'm confident the issue itself is not related, as this is quite a "passive" protocol (from my understanding) and also I'm having the issue even though I'm unplugging the Toslink cable.

I made several tests with differents adjustments to the configuration, always using aplay with the same wave file.

I noticed someting really interesting : I was able to lightly improve the playback speed by forcing the output sampling to 48000 Hz, rather than the default 44100 Hz, frequency of the file.

Here are the results :

  • With a 44100 rate parameter, the file duration was 51s instead of 60s
  • With a 48000 rate parameter, the file duration was 55s instead of 60s (better, but still too fast)

I made this measurement by a simple script with date diff before and after the aplay runs. It is in seconds, so not the most accurate, but enough to have a good idea of the issue.

So it is like if regardless of the sample rate parameter, it will always play the samples at a constant frequency. As the 48 kHz has "more samples" per seconds than the 44.1 kHz one, it seems legit that it such circumstances that the audio plays slower than the 44.1 kHz.

But I am not able to tell why it is doing so. I don't know if it is related to some alsa parameters, some internal clock settings or something else.

I did several searches about this topic, but still can't find out how to fix this issue, hopefully some experts have any idea ?

There are other related topics, mostly mentionning kernel downgrade or volumio (which I don't use) downgrade :

Any help is appreciated :)

Best regards,

Irénée

7 comments

Post is closed for comments.