0

TinkerBoard/Volumio/Digi+ Pro Build – Digi not showing in Volumio

Greetings.

Above hardware came last week and I’ve been trying to get it running since. Build went fine. Installed Volumio on Tinker to eMMC memory. Volumio boots fine and finds my music on USB. Crappy Sound outputs from Tinker HDMI to my receiver but not through any HiFiBerry output.

On the Volumio config page, HiFiBerry Digi+ Pro never displays in the Output Device or DAC Model (with I2S enabled) sections.

aplay -l doesn’t list it. The only devices listed are Tinker’s onboard USB ports.

I tried to manually add a dtoverlay for it to hw_intf.conf. No luck. I checked /boot/overlays for the driver. I see hifiberry-digi-pro.dtbo which I assume is the right driver.

I tried adding explicit references to HiFiBerry Digi+ Pro in /boot/config.txt and a config to /etc/asound.conf based on a page I found on this site.

Whenever I make config changes and restart Volumio, the UI always reports that the device found is HifiBerry Amp, but nothing outputs from the card. Dmesg log always reports that it is unable to start HifiBerry Amp.

Root cause at this point based on my observations is that I received a HiFiBerry Digi+ Pro that was incorrectly flashed as a  HifiBerry Amp card.  Does that make sense?

 Any ideas on next steps or alterative steps for troubleshooting?

Thank you.

-Chris

2 comments

Please sign in to leave a comment.