0

HifiBerryDAC+ on RPi 3 with bouncing sound and high pitched

Project: Connect my phone through bluetooth to RPi, then output using DAC to AUX input port on car.

 

I just added the DAC to my audio RPi using Pulse as my audio player.  And finally got the sound coming through the DAC instead of the RPi headphone jack.  But the sound is terrible.  It is like the sample rate is all messed up.  I am trying to play music from Pandora through BT.  I will post outputs of the various things like "aplay -l" and "aplay -L" along with config files when I can.  And if I can attach a sample of the audio I will as well.

 Follow link to hear a clip of what it is doing:

https://drive.google.com/drive/folders/1S182fI3qDWIGKEJAWuWpLDhhS3H61Pms?usp=sharing

 

 

pi@carmusic:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
pi@carmusic:~ $

pi@carmusic:~ $ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default
Playback/recording through the PulseAudio sound server
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberry_dacplus,
Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus,
Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus,
Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus,
Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dacplus,
Hardware device with all software conversions
pi@carmusic:~ $

/boot/config.txt   file(items in bold are what I have changed)

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi
dtoverlay=hifiberry-dacplus
dtdebug=1
# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
#dtparam=audio=off

 

/etc/asound.conf file

pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}

 

 

/etc/pulse/daemon.conf file(bold is the change)

; resample-method = speex-float-2
; enable-remixing = yes
; enable-lfe-remixing = no
; lfe-crossover-freq = 0
resample-method = trivial
; flat-volumes = yes

3 comments

Please sign in to leave a comment.