0

ADAU1451 EEPROM Memory Failure

Hi,

I got my long awaited BeoCreate amp and pi etc, connected everything up to a custom speaker and it has been 'working' relatively well so far.

  1. I can get Airplay to work but when i close Spotify then the service needs to be manually restarted through SSH which is kind of annoying.
  2. Bluetooth I don't generally use but it works
  3. Optical I haven't tried
  4. The Spotifyd service hasn't worked at all. I have followed all the forums here and done what I should but to no avail. I assume its a Spotifyd/repository problem as the Hifiberry & Volumio Spotify service also doesn't work.
  5. Most concerning issue is that it seems there is a memory failure on the ADAU1451 chip or EEPROM. Details below:
  • I downloaded the HifiBerry sample DSP program, made my X-Over settings and download to the Amp. No problems here, I can hear through the speaker my live setting changes etc so I know its communicating fine.
  • I go over to write the compilation and all seems to go fine
  • Click on the "Check last compilation through DSP" and it come back with a failure message (attached)

  • I can play songs fine, DSP is working, sounds great!
  • I issue a sudo reset to the pi and then when the system boots up (selfboot jumper on) I get a horrible white/pink noise coming through the speaker!https://www.dropbox.com/s/dfs382ii0ba8cbt/Speaker%20Noise.m4a?dl=0 
  • I can connect to the pi again through SigmaStudio no problem and do the "link compile download" again which promptly stops the white noise and starts playing songs again and sounding good....

I assume this can only be a memory failure on the EEPROM side of things and the board needs to go back to the supplier?

Not sure if there is anything else that I can do or check?

Any assistance would be greatly appreciated!

15 comments

Please sign in to leave a comment.