0

eeprom not working on DAC+ DSP

Hello dear HifiBerry Team

I just recently received my hifiberry dac+ dsp.

As I did not found a lot of Information about how to get started I just plugged it into my Raspberry pi 3B+ with a 7A Supply and MoodeAudio installed.

I set moode audio to use this Device but heard nothing.

Then I edited the boot config and alsa as you explain somewhere. But it was already done by moode.

So I thought nothing bad and just installed dsptoolkit.

I wrote a profile to it and look! It worked.

But it just worked until I rebooted or did the eeprom check.

The eeprom check comes with no error. But after it I have to install the profile again to hear something. The same after a reboot.

I tried with the save command which one time worked after I reinstalled the program many times. But now again it just gives me a python error as some other conmands did and do also...

I also tried the reset command and installed the profile as it was quiet again after it. But the same problem occurs

But the boiling point is the Profile which seems to be lost after every interaction with the eeprom.

Could it be defective? As I read in the readme the install profile command should write to the eeprom? So I think I did the right steps. But it just won't work anyway.

It truly would be a great device with a nice sound but like this it's useless.

Thanks for any help and have a nice day!

21 comments

Please sign in to leave a comment.