CX100 SCREAMING on power up


I've been using my beocreate board inside a CX100. It had a really scary laud pop at start, so I tended not to use it at all for a while. But this summer I saw that there was a new profile that should fix this, so I flashed a new sd-card with the new img. 

Now the speaker is instead screaming a laud beep until I pull the plug. Sounds like maximum output and I'm afraid the speaker will damage. At least my ears hurt! So while trying to reinstalling the image and trying to reapply the soundprofile for CX100 I've been holding my ears and been ready to pull the plug. 

No sound comes out with the mute jumper installed, but then I don't get any sound when streaming from Roon via shareport either. I haven't tried the optical input, but then I'm not interested in using it with the speaker closed up. 

I noticed today that when first changing to the CX50 profile and then back to CX100, there was no more screaming without the mute jumper. Hurray! But, also no sound at all when playing over shareport... So I checked the recreate/setup page and tried to change the master volume there, but I got a message that the sound profile wasn't recognized. So I reinstalled the CX100 profile, and was able to play some music. Though after a reboot it started screaming again. 

I checked the checksum from dsptoolkit and it is 18454E5C3033E17F5A11937BF90ED7E4. Is that correct? I tought that it was for the sound profile, but in this thread they are talking about the CX50 with the same checksum: https://support.hifiberry.com/hc/en-us/community/posts/360005436518-Beocreate-Loud-pops-on-start-up

I'm about to give up. Do you have any suggestions?

Oh, besides, if important, I've connected the beocreate board to a raspberry pi 3b+.


Best regards



Please sign in to leave a comment.