0

HiFiBerry DAC+ RTC: Real time clock not working

Hi everybody!

I'm trying to configure my DAC+ RTC following these guides:
(1) https://www.hifiberry.com/build/documentation/configuring-linux-3-18-x/
(2) https://www.hifiberry.com/build/documentation/dac-rtc-configuring-the-rtc-driver/#

I'm using "dtoverlay=hifiberry-dac" in my boot/config.txt.
The DAC itself works fine and sounds great under both Ubuntu Mate (my preferred OS) and Raspbian.

But I can't seem to get the RTC to work.
I put the 6 lines of code from guide (2) into both boot/config.txt and etc/modules. (Is this my first mistake right here?)

When I try to read the RTC, I get:
someuser@rp:~$ echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-1/new_device
bash: /sys/class/i2c-adapter/i2c-1/new_device: No such file or directory
someuser@rp:~$ hwclock -r
hwclock: Sorry, only the superuser can use the Hardware Clock.
someuser@rp:~$ sudo hwclock -r
[sudo] password for someuser:
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
someuser@rp:~$ sudo hwclock --debug
[sudo] password for someuser:
hwclock from util-linux 2.27.1
hwclock: cannot open /dev/rtc: No such file or directory
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.

Under Raspbian, I get:
pi@raspberrypi:~ $ echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-1/new_device
bash: /sys/class/i2c-adapter/i2c-1/new_device: Permission denied
pi@raspberrypi:~ $ hwclock -r
hwclock: Cannot access the Hardware Clock via any known method.

What am I missing?

Any help is appreciated!
Cheers,
Tati

9 comments

Please sign in to leave a comment.