0

Low / No Volume (Basic Full-Range profile)

Today I installed the latest beocreate.img and successfully completed the web based setup (using the basic full-range profile) connected to four Niles CM730 speakers.


Loading / re-loading a sound profile results in four VERY LOUD speaker noises, but once configured any audio via Bluetooth or the aplay command is either extremely low (barely audible with ear pressed against speaker) or no audio at all.

The HW seems fine (green d2 LED on beocreate board).

Some command output to hopefully help troubleshooting:

pi@library:/ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

 

pi@library:/ $ cat /boot/config.txt | more
# Enable audio (loads snd_bcm2835)
dtoverlay=hifiberry-dac
dtparam=spi=on

pi@library:/ $ cat /etc/asound.conf | more
pcm.hifiberry {
type hw
card 0
device 0
}
pcm.dmixer {
type dmix
ipc_key 1024
ipc_perm 0666
slave.pcm "hifiberry"
slave {
period_time 0
period_size 1024
buffer_size 8192
rate 44100
}
bindings {
0 0
1 1
}
}
ctl.dmixer {
type hw
card 0
}
pcm.softvol {
type softvol
slave.pcm "dmixer"
control {
name "Master"
card 0
}
min_dB -90.2
max_dB -6.2
}
pcm.!default {
type plug
slave.pcm "softvol"
}

pi@library:~ $ alsamixer
qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq AlsaMixer v1.1.3 qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
x Card: snd_rpi_hifiberry_dac F1: Help x
x Chip: F2: System information x
x View: F3:[Playback] F4: Capture F5: All F6: Select sound card x
x Item: Master Esc: Exit x
x x
x x
x x
x lqqk x
x x x x
x x x x
x x x x
x x x x
x x x x
x x x x
x xaax x
x xaax x
x xaax x
x xaax x
x xaax x
x xaax x
x xaax x
x xaax x
x mqqj x
x 60<>60 x
x < Master > x

pi@library:/ $ gpio readall
+-----+-----+---------+------+---+---Pi 3---+---+------+---------+-----+-----+
| BCM | wPi | Name | Mode | V | Physical | V | Mode | Name | wPi | BCM |
+-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+
| | | 3.3v | | | 1 || 2 | | | 5v | | |
| 2 | 8 | SDA.1 | IN | 0 | 3 || 4 | | | 5v | | |
| 3 | 9 | SCL.1 | IN | 0 | 5 || 6 | | | 0v | | |
| 4 | 7 | GPIO. 7 | IN | 0 | 7 || 8 | 0 | IN | TxD | 15 | 14 |
| | | 0v | | | 9 || 10 | 1 | IN | RxD | 16 | 15 |
| 17 | 0 | GPIO. 0 | IN | 1 | 11 || 12 | 1 | ALT0 | GPIO. 1 | 1 | 18 |
| 27 | 2 | GPIO. 2 | OUT | 0 | 13 || 14 | | | 0v | | |
| 22 | 3 | GPIO. 3 | IN | 1 | 15 || 16 | 0 | IN | GPIO. 4 | 4 | 23 |
| | | 3.3v | | | 17 || 18 | 0 | IN | GPIO. 5 | 5 | 24 |
| 10 | 12 | MOSI | ALT0 | 0 | 19 || 20 | | | 0v | | |
| 9 | 13 | MISO | ALT0 | 0 | 21 || 22 | 0 | IN | GPIO. 6 | 6 | 25 |
| 11 | 14 | SCLK | ALT0 | 0 | 23 || 24 | 1 | OUT | CE0 | 10 | 8 |
| | | 0v | | | 25 || 26 | 1 | OUT | CE1 | 11 | 7 |
| 0 | 30 | SDA.0 | IN | 0 | 27 || 28 | 0 | IN | SCL.0 | 31 | 1 |
| 5 | 21 | GPIO.21 | IN | 1 | 29 || 30 | | | 0v | | |
| 6 | 22 | GPIO.22 | IN | 1 | 31 || 32 | 0 | IN | GPIO.26 | 26 | 12 |
| 13 | 23 | GPIO.23 | IN | 1 | 33 || 34 | | | 0v | | |
| 19 | 24 | GPIO.24 | ALT0 | 1 | 35 || 36 | 0 | IN | GPIO.27 | 27 | 16 |
| 26 | 25 | GPIO.25 | IN | 0 | 37 || 38 | 0 | ALT0 | GPIO.28 | 28 | 20 |
| | | 0v | | | 39 || 40 | 0 | ALT0 | GPIO.29 | 29 | 21 |
+-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+
| BCM | wPi | Name | Mode | V | Physical | V | Mode | Name | wPi | BCM |
+-----+-----+---------+------+---+---Pi 3---+---+------+---------+-----+-----+


pi@library:/ $ speaker-test -D hifiberry -c 2
speaker-test 1.1.3
Playback device is hifiberry
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 131072
Period size range from 64 to 65536
Using max buffer size 131072
Periods = 4
was set period_size = 32768
was set buffer_size = 131072
0 - Front Left
1 - Front Right
Time per period = 2.751784
0 - Front Left
1 - Front Right
Time per period = 5.461224
0 - Front Left
1 - Front Right

Result = Sound (low but audible) is heard during speaker-test command

pi@library:~ $ aplay Music/startup.wav
Playing WAVE 'Music/startup.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Result = NO AUDIO is heard from the speakers

11 comments

Please sign in to leave a comment.