0

No sound in recording on DAC+ADC

I'm having trouble getting the dac+adc to record from a microphone. The dac+adc is the only device shown when I run aplay -l and arecord -l and it doesn't have any trouble playing but when I try to record it doesn't capture any sound. This is on a Raspberry Pi 3B+ running Raspbian 9 Stretch with Linux kernel version 4.19 and the input jumper block set to 32db gain.

The only part of the setup I'm not sure about is the microphone. I wanted to get a proof on concept up and working before I bought a nicer mic so I've been using this (https://www.amazon.com/gp/product/B0070DG2Y8/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1) cheap microphone I had lying around. I know the dac+adc only works with dynamic microphones but I'm too new to audio stuff to know if this one is compatible.

I'm pretty sure I have the config.txt set up properly but, for clarity's sake, here's the config file and the output for aplay -l and arecord -l

Config.txt:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=51

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
# dtparam=audio=on
dtoverlay=hifiberry-dacplusadc

 

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplusadc], device 0: HiFiBerry DAC+ADC HiFi multicodec-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

 

arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplusadc], device 0: HiFiBerry DAC+ADC HiFi multicodec-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

5 comments

Please sign in to leave a comment.