0

No sound from Digi+

I ordered the Digi+ Standard in january, tried for a few nights to get it working but never managed. I am not sure what (if any) error message i got then.

Tonight I decided to give it a new try.

I tried raspbian-lite using noobs max2play and hifiberry's custom image. nothing worked.

Raspbian lite and max2play gave me error messages when trying to play any file (something along the lines of  ""hifiberry" aplay: pcm_write:2011: write error: Input/output error"

Hifiberry's custom image just hangs when I try `aplay piano2.wav` (downloaded from http://www.kozco.com/tech/soundtests.html). No error message. Can't even abort it using ctrl+c.

Same when trying "play -n synth sine 1000"

It just shows 

"Encoding: n/a
Channels: 1 @ 32-bit
Samplerate: 48000Hz
Replaygain: off
Duration: unknown      
In:0.00% 00:00:00.00 [00:00:00.00] Out:0     [      |      ]        Clip:0    "

And is stuck there, not updating, and ctrl+c does not work (I have to pull the power plug).

Output of aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0

I am no linux expert, but I can't find anything in "dmesg" or "sudo vcdbg log msg" that gives me any information of what might be wrong.

 

3 comments

Please sign in to leave a comment.