0

dtoverlay=hifiberry-dacplus won't load, no sound

Hi,

I've been trying to get my Hifiberry DAC+ Standard HW2.6 working for a few days on a raspberry pi 3B using Raspbian 2017-11-29 without success (kernel 4.9 and then updated to 4.14).

Using the dacplus overlay:-

dtoverlay=hifiberry-dacplus

I get the following in dmesg

pi@raspberrypi-audio:~ $ dmesg | grep hifi
[   30.756760] snd-rpi-hifiberry-dacplus soc:sound: ASoC: CPU DAI (null) not registered - will retry
[   30.759539] snd-rpi-hifiberry-dacplus soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry

Nothing will show up in aplay -l, amixer,  alsamixer

Interestingly (or not?), if i use the dac overlay:-

dtoverlay=hifiberry-dac

I get the following in dmesg

pi@raspberrypi-audio:~ $ dmesg | grep hifi
[    6.123373] snd-hifiberry-dac soc:sound: ASoC: CODEC DAI pcm5102a-hifi not registered - will retry
[    6.125715] snd-hifiberry-dac soc:sound: pcm5102a-hifi <-> 3f203000.i2s mapping ok

Then i can also see it in aplay -l

pi@raspberrypi-audio:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

However amixer has no output. alsamixer says "This sound devices does not have any controls."

Not sure what the issue could be...? Hopefully simple user error on my part ;)

  • I upgrade the kernel thinking that might do it but no difference for me between 4.9 and 4.14.
  • Also tried runeaudio (kernel 4.1), no success.
  • dtparam=audio=on doesn't make any difference.
  • disabling wifi/bt doesn't make any difference (saw an issue referring to this, it was a few years old but i thought i'd try just for completeness).

 

Extra info

Kernel

pi@raspberrypi-audio:~ $ uname -r
4.14.24-v7+

My /boot/config.txt

pi@raspberrypi-audio:~ $ cat /boot/config.txt 
# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
#dtparam=audio=on
dtoverlay=pi3-disable-wifi
dtoverlay=pi3-disable-bt
dtoverlay=hifiberry-dacplus

3 comments

Please sign in to leave a comment.