Hifiberry Digi+ Pro


I got my new Hifiberry Digi+ Pro version 2 days ago and im having trouble making it work.

I have a Pi3 and so far used Volumio to listen to music with a cheap analog hat without a problem.

When i got my Hifiberry Digi+ Pro with my new 2.5amp psu i got also the steel

case and a new sd card and installed the latest 2.031 Volumio on it.

I opened the Volumio web interface and i saw that it had detected the

Hifiberry Digi as output device prolly from eprom read ?


I also enabled i2s support and selected Hifiberry Digi there too and restarted Volumio.

I loaded some music and tried to get output first from Coax and then from optical output without a success.

Music playback started and i had no out from both digital outs.

After spending hours restarting resetting testing the hdmi and analog out that

worked without a problem found that i can't get out on my new Digi+ Pro.

I manualy edit the config file and set the parameters for my digi+ Pro and result was the same.

Also i have to say that when i have the Hifiberry Digi+ Pro mounted on the Pi

Volumio Web Interface hangs after 3-5 minutes and the only way to get it back

is to remove the plug and power it up again. When the Web interface is down i

can SSH the pi and login there without a problem, but the web interface gets

down. This DOESNT happen at all when the Hifiberry Digi+ Pro isn't attaced on

the Pi3.

I also tried RuneAudio just to check if the issue is with Volumio. I had the

same results.

The Digi Pro is detected by RuneAudio and i have no sound output at all, only

from analog and HDMI.

RuneAudio also crashes after few minutes of playback when the Hifiberry Digi+

Pro is attached on the Pi.

My last attempt after changing 3 different PSU different sd cards and trying

Volumio and Runeaudio was to try SD Card images and Raspian with Tone

Generator to check if my hardware was ok.


After booting up i had No Tone at all neither from Digital or Optical out on my

Digi+ so i am assuming i have faulty hardware ?

Is there something else to check ?

Been searching the net and forums for solutions the last two days without any

possitive result...





Please sign in to leave a comment.