0

LCD HD44780 20x4 problem

Hello to everybody;
my name's Massimo and I'm writing from Italy.
I'm trying to build my own hifi based on OSMC, Raspberry 2, Hifiberry Digi+ and Hitachi HD44780+PCF8574AT 20x40 LCD (to show the tracks information).
I have no problems with the base setup OSMC + Raspberry + Hifiberry but I'm not able to get any feedback from the LCD.
I'm trying to fix the problem since the beginning of the year without success, the LCD is turned on but no reactions
I followed many tutorial and the last very helpful one was at this limk: https://discourse.osmc.tv/t/howto-lcd-hd44780-throught-i2c-port-extender/169041
I did it exactly as is writed and by it I've got only the LCD blinking in continuous.
The only feedback not in according to the tutorial is that the address of the i2c is "3f" that seems strange to me (from what I've understood it have to be from 0x20 to 0x40)

In some tutorials I've found that the LCD use some of the GPIO of the Hifiberry:

setgpio 2 ALT0 UP # I2C communication DAC chip
setgpio 3 ALT0 UP # I2C communication DAC chip
setgpio 6 INPUT DEFAULT # do not use, reserved for Master clock
setgpio 18 ALT0 DEFAULT # I2S
setgpio 19 ALT0 DEFAULT # I2S
setgpio 20 ALT0 DEFAULT # I2S
setgpio 21 ALT0 DEFAULT # I2S

My PCF8574AT is wired in this way:

SCL position 5 GPIO2
SDA position 3 GPIO3
VCC position 4 5V
GND position 6 ground

I saw a lot of working systems with the LCD so I'm doing something wrong for sure, but I'm not able to undersand it

Thank you very much to everybody

Massimo

0 comments

Please sign in to leave a comment.