0

No sound with DAC+

My DAC+ had been working but after some hardware and software changes, it has stopped.

Here's the story.

I removed the DAC+ from my rpi 3 to solder on a header that I want to use for an ir receiver. At the same time, I did a fresh install of OSMC and Raspbian using NOOBS

I re-installed the DAC+ and tested with OSMC (after adding the appropriate lines to /boot/config.txt) and all was well. I made a few small configuration changes to OSMC and rebooted, and -- no more sound after the reboot.

aplay -l does show the card as expected. When I try to aplay a wav file, I get:

osmc@pi3:~$ aplay test.wav

Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 16000 Hz, Mono
aplay: set_params:1239: Channels count non available

and no sound is produced. I tried the same thing with Raspbian, with the same result.

It is possible that I did some damage while soldering the header to the DAC+, but it did work fine initially, until I rebooted.

Any suggestions?

Frank

1 comment

Please sign in to leave a comment.