0

DAC+ Light Recognized but no sound

Hi,

I have a raspberry pi 3 running raspbian (jessie).  I've been trying to get a DAC+ light to work with it but have been running into issues.  

The DAC+ light is listed when I run "aplay -l" and no other sound card is listed, but there's no sound when I try to play music, etc.  However, when I run

wget www.hifiberry.com/files/dac/check-system
mv check-system check-system.dac
chmod u+rx ./check-system.dac
./check-system.dac

 the test tone is played.

I started by following these instructions: https://www.hifiberry.com/guides/configuring-linux-3-18-x/

 But when I ran into problems I found these instructions and tried them out: https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher

 

 

Here is a portion of the output from dmesg that looks related:

[    3.775045] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered

[    3.777760] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517

[    4.046065] systemd-udevd[139]: starting version 215

[    4.437935] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer

[    4.438183] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered

[    4.438201] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517

[    4.444918] gpiomem-bcm2835 3f200000.gpiomem: Initialised:

Registers at 0x3f200000

[    4.445211] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered

[    4.445233] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517

[    4.478083] snd-hifiberry-dac soc:sound: pcm5102a-hifi <->

3f203000.i2s mapping ok

[    4.732542] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)

[    4.814180] usbcore: registered new interface driver brcmfmac

[    5.037611] brcmfmac: brcmf_c_preinit_dcmds: Firmware version =

wl0: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c

[    5.041465] random: nonblocking pool is initialized

[    5.057946] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code

[    5.226548] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code

 

Any ideas?

3 comments

Please sign in to leave a comment.