0

Setting up DAC+ for Raspberry 3 on Jessie

Hello,

I have purchased a Hifiberry DAC+ last year, and have greatly enjoyed the fantastic sound quality it provides. Paired with a Raspberry Pi 2 and Topping NX1 Portable Amp, the system works great and I carry it around with me all the time.

However, this month I have just bought a new Raspberry Pi 3, and I'm thinking about migrating the DAC to the new board. I have used the latest 20160229 NOOBS image, and have set up the WiFi, as well as disabled Bluetooth with dtoverlay=pi3-disable-bt (as suggested by the new post on compatibility).

 

However, a problem I met was that, the blacklist file in /etc/modprob.d/raspi-blacklist.conf is empty and doesn't have any blacklisted drivers (which should have been "i2c-bcm2708", "snd-soc-pcm512x" and "snd-soc-wm8804").

Moreover, /etc/modules does not contain the line "snd_bcm2835" (Although in my old Wheezy image on RPi2, the line is there, and could be commented out) Therefore I couldn't seem to disable the system sound card module, and although DAC+ can be recognized as card 1, it doesn't play sound since snd_bcm2835 takes card 0.

Eventually, I tried a workaround and added "blacklist snd-bcm2835" in raspi-blacklist.conf, and the system sound card seems to be disabled and DAC+ can play sound. However, I noticed that the sound quality was not as good as before (some distortion is present and the soundstage is narrower...), at first the volume was too loud, too, until I turned down the system volume, but the sound quality still sounds a bit off...

 

May I ask what might have caused the problem? Would the "workaround method" cause problems, or perhaps some drivers have not been removed from the blacklist?

Also, I noticed that, when playing songs with mplayer, the "ratio" has changed from previously 40003->352800 on RPi2 to 40000->176400 on RPi3, I wonder if this has anything to do with the problem...?

Thank you very much!

Mike

 

P.S. Attached are screenshots of mplayer playing on Pi2 and Pi3. And the output of aplay -l (which seems to be the same as shown in tutorial...)

 

 

1 comment

Please sign in to leave a comment.