0

Fix for Digi+ on RPi3 - disable bluetooth

Hi

After spending time working with the Linux kernel community we've managed to at least identify the source of the problem for playback with either the Digi+ or DAC-Pro. The fix to this problem is to disable the bluetooth hardware by adding the following dtoverlay to your /boot/config.txt

dtoverlay=pi3-disable-bt

Reboot and this should hopefully resolve the sound playback problem.

The technical: There is some conflict between the I2S serial audio and bluetooth data channels on the RPi3's Broadcom chip. It is specific to the Digi+ and DAC-Pro because the DAC chips produce their own bitclock signals and the root of the problem was that the RPi3 was not sending audio data in sync to the DAC's clock signal when bluetooth is enabled.

The Raspberry Pi developers are still looking into this, therefore there might be a fix in the future that allows to use the HiFiBerry card and the bluetooth module.

All the best,

Stuart

8 comments

Please sign in to leave a comment.