0

Problem configuring alsa equalizer

Good morning,

Recently bough DAC+ and configured Raspbian. MPD sounds nice, but "sliding" alsamixer controls make no sound difference. Also, some tests like using aplay fail.

 

$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

 

$ aplay Noise.wav
Playing WAVE 'Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1239: Channels count non available

 

I configured it just adding to /boot/config.txt

#hifiberry
dtoverlay=hifiberry-dacplus



$ lsmod
Module Size Used by
cfg80211 389253 0
rfkill 16036 1 cfg80211
snd_soc_pcm512x_i2c 2091 1
snd_soc_pcm512x 15589 1 snd_soc_pcm512x_i2c
regmap_i2c 2684 1 snd_soc_pcm512x_i2c
sg 18023 0
snd_soc_hifiberry_dacplus 3820 6
snd_soc_hifiberry_dac 2367 0
snd_soc_bcm2708_i2s 6670 2
regmap_mmio 2842 1 snd_soc_bcm2708_i2s
snd_soc_core 127477 4 snd_soc_pcm512x,snd_soc_hifiberry_dac,snd_soc_hifiberry_dacplus,snd_soc_bcm2708_i2s
snd_compress 7689 1 snd_soc_core
snd_pcm_dmaengine 3231 1 snd_soc_core
snd_pcm 73442 5 snd_soc_pcm512x,snd_soc_core,snd_soc_hifiberry_dac,snd_pcm_dmaengine,snd_soc_hifiberry_dacplus
snd_timer 18792 1 snd_pcm
i2c_bcm2708 4920 0
bcm2835_gpiomem 2860 0
snd 50779 16 snd_soc_core,snd_timer,snd_pcm,snd_compress
bcm2835_rng 1763 0
clk_hifiberry_dacpro 2098 1
uio_pdrv_genirq 2944 0
uio 7753 1 uio_pdrv_genirq
i2c_dev 5671 0
fuse 80694 3
ipv6 338574 42

 

Updated kernel and packages

$ uname -a
Linux raspberrypi 4.1.18-v7+ #846 SMP Thu Feb 25 14:22:53 GMT 2016 armv7l GNU/Linux

 

Created asound.conf to enable equalizer, but it makes no difference on aplay results. Copied from your guide:

 

$ cat /etc/asound.conf
pcm.!default {
type plug
slave.pcm plugequal;
}
ctl.!default {
type hw card 0
}
ctl.equal {
type equal;
}
pcm.plugequal {
type equal;
slave.pcm "plughw:0,0";
}
pcm.equal {
type plug;
slave.pcm plugequal;
}

 

At /etc/mpd.conf just added the hardware volume control:

 

audio_output {
type "alsa"
name "My ALSA Device"
# device "hw:0,0" # optional
# mixer_type "hardware" # optional
# mixer_device "default" # optional
# mixer_control "PCM" # optional
mixer_control "Digital"
# mixer_index "0" # optional

 

I'm not a linux expert and, after several days looking for a clue on forums and mans, couldn't get a solution by myself. Would really appreciate your help.

Thanks in advance.

6 comments

Please sign in to leave a comment.