0

DAC+ installation issues

 

 

I've just received a RPi3 and DAC+ (minijack) bundle and not getting any joy with the Pi recognising the board. I've tried Raspbian and Arch via the HiFiBerry Installer and also the test tone image.

 

This is the relevant bit of dmesg output-

 

[    8.110387] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[    8.110422] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[    8.122382] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    8.320841] cfg80211: Calling CRDA to update world regulatory domain
[    8.386637] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[    8.386687] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[    8.398682] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
[    8.399808] usbcore: registered new interface driver brcmfmac
[    8.400362] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[    8.400380] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[    8.570532] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c
[    8.593663] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    8.667091] bcm2835-rng 3f104000.rng: hwrng registered
[    8.667472] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[    8.667493] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[    8.675338] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 79) (baudrate 100000)
[    8.675589] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[    8.675607] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[    8.676267] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[    8.676289] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[    8.799019] pcm512x 1-004d: Failed to reset device: -5
[    8.799151] pcm512x: probe of 1-004d failed with error -5
[    8.934446] systemd-journald[105]: Received request to flush runtime journal from PID 1
[    9.110304] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code

 

sudo vcdbg log msg gives me lots of lines like this-

691948.402: gpioman: gpioman_get_pin_num: pin LEDS_FATAL_ERROR not defined
691948.426: gpioman: gpioman_get_pin_num: pin LEDS_APP_OK not defined
691948.450: gpioman: gpioman_get_pin_num: pin LEDS_APP_FAILED not defined
691948.472: gpioman: gpioman_get_pin_num: pin LEDS_HDCP_AUTH not defined
 

Look like a H/W issue? Don't have another Pi to hand today to test but can get hold of one tomorrow.

 

Any advice would be much appreciated!

 

0 comments

Please sign in to leave a comment.