0

DAC+ not working

Hello,

I recently bought a DAC+ Standard RCA version but I face this problem now:

I get no sound. No matter what I try, nothing works.

I started with a clean installation of the current raspbian and followed your steps for configuring 3.18+ kernel versions. Then I tried your test-image and finally I am now using an image I got from your windows-installer.

 

Whenever I try "speaker-test -c 2", the yellow LED on the DAC+ turns on, but I can't hear anything from my speakers. When I pull out the RCA-Cables and touch the pin, it crackles from the speakers, so the cable is fine.

In dmesg I get the following:

 

[ 5.118124] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 79) (baudrate 100000)
[ 5.146772] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f2 00000
[ 5.225680] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registe red
[ 5.225717] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.227020] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ 5.227054] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.497353] Bluetooth: Core ver 2.20
[ 5.497482] NET: Registered protocol family 31
[ 5.497498] Bluetooth: HCI device and connection manager initialized
[ 5.497536] Bluetooth: HCI socket layer initialized
[ 5.497563] Bluetooth: L2CAP socket layer initialized
[ 5.497623] Bluetooth: SCO socket layer initialized
[ 5.524650] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ 5.524691] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.530191] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ 5.530225] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.530448] usbcore: registered new interface driver btusb
[ 5.569642] random: nonblocking pool is initialized
[ 5.578316] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[ 5.578986] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 5.620418] snd-rpi-hifiberry-dacplus sound: pcm512x-hifi <-> 3f203000.i2s ma pping ok

 

Do you have a tip for me? Is there a "hidden" volume-control that I need to set high first?

 

I will appreciate any help!

Thanks in advance,

Thomas

17 comments

Please sign in to leave a comment.