0

Runeaudio / Amp+ hardware volume control

Boyd created this guide how he enabled hardware volume control in Runeaudio:

 

Success! I now have RuneAudio working with HiFiBerry AMP+, Hardware Volume Control enabled, and the nasty buzzing sound has gone.
Thank you for your help in pointing me in the right direction.

I tried out your suggestion of switching to Moode Audio, but I could not get it to recognize my NAS drive.
Several other people reported this problem, so I persevered with Rune.

Originally (when I was experimenting with DAC+) I used Volumio - following the tutorial on the HiFiBerry website. This would play my recorded music OK, but I could not get Web Radio to work with a list of UK radio stations. I have verified that the URLs were correct - they would play through my PC, but not on Volumio. As my end-goal was to replace my CD-player / Tuner / Amplifier stack, I wanted Internet Radio to work. This led me to try Rune as an alternative

I could add my URLs individually to Rune, and they all worked. I also like being able to see CD covers on Rune (not available on Volumio) So Rune seemed to be a better platform for me, apart from the buzzing noise when I switched from DAC+ to AMP+

This was cured by enabling the Hardware Volume control in Rune.

This involved a few steps, but I was successful in the end.

Here is how I arrived at a solution.

1. Download the appropriate image of Rune 0.3 (the version for Pi2) and write to an SDHC card

2. Edit the config.txt file on the SDHC card (using notepad on my PC, to the attached version - uncomment the lines for
device_tree_param=i2s=on
and
device_tree_overlay=hifiberry-amp

3. Insert the SDHC card and power up the Pi / HiFiBerry AMP+, connected by Ethernet

4. Open an internet Browser and navigate to RuneAudio/local

5. Set up: NAS; time zone; WLAN; and enable hardware volume control and reboot

All straightforward to this point, but Hardware Volume control needs the following steps

6. Use PuTTy to log-in the the Pi - user name root, password rune

then type the following

cd /srv/http
git stash
git pull

wait until stuff happens!

7. type nano /etc/mpd.conf

scroll down and find the audio output section, and change the rpi hifiberry amp section to look like this:

audio_output {
name "snd_rpi_hifiberry_amp"
type "alsa"
device "hw:1,0"
mixer_type "hardware"
mixer_control "Master"
mixer_device "hw:1"
mixer_index "0"
auto_resample "no"
auto_format "no"
enabled "yes"
}

press ctrl-x to exit from the nano editor, and press Y to save the buffer to the mpd.conf file

type exit to close the PuTTY session

8. Open browser and navigate to RuneAudio (if you have closed the browser while using PuTTY, but this in not necessary)

Now look at MPD on Rune - it should now look like this:

you can click on Manual Edit, then scroll down and verify the changes you made using PuTTy

(It would be nice to be able to do these changes from Rune, but I haven't figured out how to do this without changing things through PuTTY)

9. Select some music from the library, and play with Hardware Volume control enabled - no buzzing!
(There is very little audio output at volumes below 60, but the 40 steps from 60 to 100 are fine for me.

Regards,

Boyd.

 

0 comments

Please sign in to leave a comment.