0

DAC+ Pro and RTC module

Hi,
I bought one DAC+ PRO for a project in a museum where a sound has to be read every day at the same hour ; so I firstly configured a raspberry PI 2 with an RTC module (DS 3231) because no cable is allowed and the PI must get the real time.
The very small PA system works with batteries and everything is rigged between ground and ceiling.
Because of the mediocrity of the analog output on the PI, I tried the DAC+ PRO : sound is great and I'll use it for another project : because of the complexity in using two I2C modules on the same GPIOS, I had to choose and RTC was the priority, unfortunately.
Problem : the RTC isn't recognized anymore.
Exactly like that :
"However, when I use i2cdetect, it shows 0x68(which is my RTC slave address) is having the status "UU", which means "Probing was skipped, because this address is currently in use by a driver". And after I tried the i2cget, its givng "could bot set address to 0x68: Device or resource busy".

Is it possible that the preceeding installation of the DAC keeps the I2C busy ?

How can I do ?

 

Thank you for the anwser : I'm in a pretty bad situation because the exhibition opens tomorrow....

O.

I have to find a solution tomorrow because

5 comments

Please sign in to leave a comment.