0

DAC+ on Rpi2 with kodi 14.2 / OpenELEC 5.0.8 on berryboot: no sound/not installed

Hi,

maybe it's two seperate issues I have here:

A. First attempt was to enable DAC+ Standard phone jack board on RPI2 with berryboot via:

dtoverlay=hifiberry-dacplus
dtdebug=1

as in https://www.hifiberry.com/guides/configuring-the-sound-card-in-openelec-with-device-tree-overlays/

-> I used the config.txt of berryboot, since I thought this would be used but I tried as well to create one in /flash with th two lines - however,

vcdbg log msg

didn't give me any hint i tried to load any hifiberry component.

I felt stuck after some hours and decided I'm an idiot and tried something different as you suggested, downloaded your Raspbian with test tone generator from
https://www.hifiberry.com/guides/sd-card-images/
Installed on a new, empty SD card, it detected the card - so it seemed, I misunderstood something about berryboot and config.txt handling.

But: when the sound started to play - there was no output. I double checked the amplifier and I tried a headphone on the port - not the slightest sound hearable, just some loud scratching if I move the plug in the jack.

So on one side - it looks like an error on my side. However, the second test seems weird.

Anything I could check to get the card to work?

Best regard
Micha from Dusseldorf


 

8 comments

Please sign in to leave a comment.