0

AMP+, Raspberry Pi 2 B and Arch Linux ARM

Hi,

I'm trying to set up my AMP+, Raspberry Pi 2 B on Arch Linux ARM. But so far I can't get a sound from it (but a silent pop at boot and a very silent high pitched noise). I did the following:

1. Added the line dtoverlay=hifiberry-amp to /boot/config.txt.
2. Added the alsa alias from your page to /etc/asound.conf.
3. Added myself to the audio group, since audio devices are owned by audio (guess that's arch-specific).

Kernel seems to succesfully register the AMP+, but one error message:
...
[ 7.819111] random: nonblocking pool is initialized
[ 7.834892] systemd-journald[137]: Received request to flush runtime journal from PID 1
[ 9.407316] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[ 9.446432] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 79) (baudrate 100000)
[ 9.455016] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 9.579811] snd-hifiberry-amp sound: ASoC: CPU DAI (null) not registered
[ 9.588692] snd-hifiberry-amp sound: snd_soc_register_card() failed: -517
[ 9.759834] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 10.692152] snd-hifiberry-amp sound: tas5713-hifi <-> 3f203000.i2s mapping ok
[ 10.707119] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[ 10.715659] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.238749] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 12.248232] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

aplay -L (default is the alias I added through the asound.conf):
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
default:CARD=sndrpihifiberry
snd_rpi_hifiberry_amp,
Default Audio Device
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberry_amp,
Default Audio Device

aplay -l (looks fine to me):
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_amp], device 0: HifiBerry AMP HiFi tas5713-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

Some testing:

> aplay: set_params:1297: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: S16_LE
SUBFORMAT: STD
SAMPLE_BITS: 16
FRAME_BITS: 16
CHANNELS: 1
RATE: 48000
PERIOD_TIME: 125000
PERIOD_SIZE: 6000
PERIOD_BYTES: 12000
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 24000
BUFFER_BYTES: 48000
TICK_TIME: 0
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 24000
BUFFER_BYTES: 48000
TICK_TIME: 0

> aplay -D default /usr/share/sounds/alsa/Front_Center.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1297: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: S16_LE
SUBFORMAT: STD
SAMPLE_BITS: 16
FRAME_BITS: 16
CHANNELS: 1
RATE: 48000
PERIOD_TIME: 125000
PERIOD_SIZE: 6000
PERIOD_BYTES: 12000

> mplayer /usr/share/sounds/alsa/Noise.wav
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] Unable to set hw-parameters: Invalid argument
AO: [pulse] Init failed: Connection refused
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
[JACK] cannot open server
[AO SDL] Samplerate: 48000Hz Channels: Mono Format s16le
[AO_ALSA] alsa-lib: pcm_hw.c:1583:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-16): Device or resource busy
[AO SDL] Unable to open audio: No available audio device

I tried it with and without pulseaudio, tried to enable different things in /boot/config.txt. The next step for me would be to test it with another image, to ensure that my Hifiberry AMP is working. But maybe someone sees what I'm doing wrong.

1 comment

Please sign in to leave a comment.