0

Hifiberry Digi+ not present in RasPlex

Hi,

A few days ago I received a new Hifiberry Digi+ (with output transformer) to install in my RPi2.
I am running RasPlex v0.6.0 (latest beta) which is supposedly compatible with the Digi+ (as it is based on Openelec).

Unfortunately the RasPlex forum is out of service and I cannot read any solutions or try to contact anyone there.

I have tried everything I could (I am not a unix expert!) and as I have two RPi2s I have tried both and twice I got the same result: I cannot see the card so I cannot choose it as audio output.

I have added "dtoverlay=hifiberry-digi" to the config.txt file.
(the only changes I made to the standard config.txt file were this, plus the "dtdebug=1" and I commented "hdmi_force_hotplug=1")

Using SSH into the RPi2 I can see after running "dmesg":

[ 5.012026] lirc_dev: IR Remote Control driver registered, major 248
[ 5.028496] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[ 5.097377] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered
[ 5.097439] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517
[ 5.097475] platform sound: Driver snd-hifiberry-digi requests probe deferral
[ 5.101476] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered
[ 5.101552] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517
[ 5.101588] platform sound: Driver snd-hifiberry-digi requests probe deferral
[ 5.105366] pinctrl-bcm2835 3f200000.gpio: pin gpio18 already requested by lirc_rpi; cannot claim for 3f203000.i2s
[ 5.105391] pinctrl-bcm2835 3f200000.gpio: pin-18 (3f203000.i2s) status -22
[ 5.105405] pinctrl-bcm2835 3f200000.gpio: could not request pin 18 (gpio18) from group gpio18 on device pinctrl-bcm2835
[ 5.105415] bcm2708-i2s 3f203000.i2s: Error applying setting, reverse things back
[ 5.114965] wm8804 1-003b: revision E
[ 5.119210] snd-hifiberry-digi sound: wm8804-spdif <-> 3f203000.i2s mapping ok
[ 5.795114] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup

However when I run "aplay -l" I get the following (which seems to suggest it being there):

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

But in the Preferences screen for RasPlex the only Audio Output options available are "HDMI" and "Analog".

Debugging is active and the log shows:

001628.104: Loaded overlay 'hifiberry-digi'
001636.749: dtdebug: Found fragment 0 (offset 36)
001641.744: dtdebug: merge_fragment(/sound,/fragment@0/__overlay__)
001641.769: dtdebug: +prop(compatible)
001642.024: dtdebug: +prop(i2s-controller)
001642.485: dtdebug: +prop(status)
001642.834: dtdebug: merge_fragment() end
001642.900: dtdebug: Found fragment 1 (offset 168)
001644.827: dtdebug: merge_fragment(/soc/i2s@7e203000,/fragment@1/__overlay__)
001644.851: dtdebug: +prop(status)
001645.491: dtdebug: merge_fragment() end
001645.576: dtdebug: Found fragment 2 (offset 244)
001648.470: dtdebug: merge_fragment(/soc/i2c@7e804000,/fragment@2/__overlay__)
001648.494: dtdebug: +prop(#address-cells)
001649.029: dtdebug: +prop(#size-cells)
001649.569: dtdebug: +prop(status)
001651.589: dtdebug: merge_fragment(/soc/i2c@7e804000/wm8804@3b,/fragment@2/__overlay__/wm8804@3b)
001651.614: dtdebug: +prop(#sound-dai-cells)
001652.185: dtdebug: +prop(compatible)
001652.698: dtdebug: +prop(reg)
001653.243: dtdebug: +prop(status)
001653.858: dtdebug: merge_fragment() end
001653.884: dtdebug: merge_fragment() end

The output of lsmod is as follows:

Module Size Used by
snd_soc_bcm2708_i2s 5975 2
regmap_mmio 2050 1 snd_soc_bcm2708_i2s
snd_soc_wm8804 6587 1
regmap_spi 1336 1 snd_soc_wm8804
regmap_i2c 1932 1 snd_soc_wm8804
snd_soc_hifiberry_digi 2791 0
snd_soc_core 102175 3 snd_soc_wm8804,snd_soc_hifiberry_digi,snd_soc_bcm2708_i2s
snd_compress 6940 1 snd_soc_core
snd_pcm_dmaengine 2811 1 snd_soc_core
snd_pcm 60510 3 snd_soc_wm8804,snd_soc_core,snd_pcm_dmaengine
lirc_rpi 5970 3
snd_timer 16303 1 snd_pcm
snd 39202 4 snd_soc_core,snd_timer,snd_pcm,snd_compress
lirc_dev 7618 1 lirc_rpi
rc_core 14619 1 lirc_dev
bcm2708_rng 801 0


Not sure how to read these logs, to be honest, but hopefully someone here will be able to tell me what is wrong...
If there is any further info you need from me just let me know.

Many thanks for any help!
I.

13 comments

Please sign in to leave a comment.