Digi+: device or resource is busy

I've used the digi+ together with squeezeplug for a year. I use the squeezelite player and the Digi+ as soundcard. It has been working without any problems.

Then today I configured WIFI with the PI and tried to connect to it without ethernet cable. My pi got a new IP from the router and all was good. But the squeezelite player configuration inside LMS server was still the old one, so i decided to remove the old player, install squeezelite again and auto discover the new one. But this does not work.

I used this guide (as I did the very first time I set it up):

The sound card is no longer found. When I type "aplay -l" it says: aplay: device_list:252: no soundcards found...
When I switch to root user and try it finds the soundcard:
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

I tried the diagnostics tool "/etc/modprobe.d/check-system.dac":
aplay: main:682: audio open error: Device or resource is busy
I get the same if I try to play demo sound in Squeezelite setup...

How can I solve this problem?


Please sign in to leave a comment.