No sound on HiFiBerry Digi+


I am running HiFiBerry Digi+ on top of the Raspberry Pi 2 Model B, but I am not getting anything on optical (TOSLINK) output.

First I have installed Volumio 1.55. When using 'Hifiberry +' or 'Hifiberry Digi' I2S drivers (NOTE: I have tried both options as I was not sure which of the two is applicable to HiFiBerry Digi+), I get no sound on my old Yamaha RX-V 450 receiver. (reboot was each time after making changes in Volumio). I found some threads discussing compatibility with old DAC's used in Yamaha receivers, but I am not sure this is applicable at this moment, due to the reason that I don't see any signal on the optical cable. I don't have any electronic measuring equipment to confirm, but I see that the optics in the cable are not showing any red light. Would this be enough to confirm that no signal is sent via TOSLINK?

I have also used the Raspbian image with test tone generator with the same result. I hope I was doing it right. Image was applied to the SD card and device was started. That's it, right?

When I use Volumio with the standard Pi's 3.5mm audio jack, all is working correctly.

I haven't had the chance to test the coaxial output yet, but I plan to do it.

Do you have any advice on the next steps?



Please sign in to leave a comment.