0

RPI 2 & OSMC RC2 & Hifiberry Digiplus -> found soundcard but no sound

Hi,

I've got a problem with my installation. I've done everything that is mentioned here:
https://www.hifiberry.com/guides/configure-osmc-for-hifiberry/

I just changed the input for /etc/modules in the following way:

ssh -l pi ip-of-your-raspberrypi
$ sudo bash
# cat >/etc/modules <<EOT
snd_soc_hifiberry_digi
EOT
# reboot

and I got the right output (I think):

osmc@osmc:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

I enabled the hifiberry-digi overlay config in the osmc menu and set the hifiberry as audio output. But there is no sound hearable. Even when I scroll through the osmc menu, there is no sound! The hifiberry overlay has a green led that is solid and the toslink emits red light (solid, should blink a bit if I play sound, right?) Did I forgot something?

Thank you very much!

8 comments

Please sign in to leave a comment.