0

probe deferral on RPi2, DAC+, Raspbian vanilla fully updated

Greetings. I have a RPi2 working well by itself, using vanilla Raspbian fully updated; just added the DAC+ and did the config items I found in the support pages; the green LED works, but it says probe deferral and failed. A snippet of my dmesg is below, the full is here. My /boot/config.txt is

[ 4.916068] bcm2708_spi 3f204000.spi: master is unqueued, this is deprecated
[ 5.010294] bcm2708_spi 3f204000.spi: SPI Controller at 0x3f204000 (irq 80)
[ 5.031164] bcm2708_i2c_init_pinmode(1,2)
[ 5.031832] random: nonblocking pool is initialized
[ 5.076932] bcm2708_i2c_init_pinmode(1,3)
[ 5.218447] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[ 5.251582] pcm512x 1-004d: No SCLK, using BCLK: -2
[ 5.266846] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.311007] platform sound: Driver snd-rpi-hifiberry-dacplus requests probe deferral
[ 5.328394] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 79) (baudrate 100000)
[ 5.344454] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[ 5.344531] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ 5.344566] platform sound: Driver snd-rpi-hifiberry-dacplus requests probe deferral
[ 5.392377] snd-rpi-hifiberry-dacplus sound: ASoC: CPU DAI (null) not registered
[ 5.408942] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517

1 comment

Please sign in to leave a comment.