No sound over Hifiberry digi

Hey folks,

after trying almost every possible Solution I still have no sound using the Hifiberry digi.

I'm using a Raspberry PI with raspbmc 3.12.31 #2 PREEMT Wed Oct 29 09:24:56 UTC2014 armv6l GNU/Linux and XBMC 13.2 git20140901-867305b (Compiled: Oct 31 2014).

I configured within the help of the installation guide. LEDs are working and SPDIF is working (red light).

At the beginning I could see 2 soundcards:

aplay – l

card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: sndrpihifiber_1 [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

At this time it was only possible to activate the hifiberry DAC in the XBMC setup. After some researches I found out that I had to disable the DAC module so I did:


After rebooting aplay -l just showed the digi soundcard and it could be configured in XBMC:


But still no sound. :( I also tried activating and deactivating passtrough, but it didnt work.

Testing the soundcard in rasbmc shows the following:


So I tried the test image which plays a sound for 5 minutes

The result was the following message (and of course no sound): "Failed to set WM8804 SYSCLK, unsupported samplerate


After that I tried the preconfigured OpenElec image offered by the hifiberry site. That didnt work too.

aplay - l just showed that no soundcard was found.

Whats the problem? Do you have any more ideas?

thx Eric


Please sign in to leave a comment.