0

Raspbmc and DAC+: confusion between DAC and DAC+

Hi,
I would very much welcome some help with the installation of my new Hifiberry DAC+.

I have a Raspberry Pi B+ on which I installed Raspbmc via Noobs.

I have added the DAC+ and followed the instructions by executing rpi-update, getting the kernel updated to the last version, installing alsa-utils, and added the lines on /etc/modules:
snd_soc_bcm2708
bcm2708_dmaengine
snd_soc_hifiberry_dacplus

For good measure I also edited asound.conf as prescribed.

The result is that when I type aplay -l I get the very reassuring message:
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

At this point as far as I understand the process I should be all set. The last step is to activate "External audio cards" in RSBPMC settings and reboot. However as soon as I do that, upon reboot, I get the following by typing aplay -l:
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiber_1 [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

So the system apparently thinks there are both a DAC and a DAC+, but when I get to the XBMC audio output options I only have the DAC (snd_rpi_hifiberry_dac) and not the DAC+. Needless to say when I activate the DAC it does not give any sound.

Can anybody help me with this? It seems very close to work but I don't know what to do to fix it.

Thank you very much in advance.

5 comments

Please sign in to leave a comment.