0

Hardware issue with HifiBerry Digi

My Hifiberry digi worked like a charm for about half a day and since then I am having difficulties to get it back to work.
I initially used volumio but I tried today with a simpler setup just using a fresh raspbian install + rpi-update and modules configuration.

It is still not working. Here is output for aplay -l
aplay: device_list:252: no soundcards found...


Here is output of check-system.dac
Checking system

Linux raspberrypi 3.10.37+ #669 PREEMPT Tue Apr 15 14:44:32 BST 2014 armv6l GNU/Linux
Kernel: 3.10.37+
PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
NAME="Raspbian GNU/Linux"
VERSION_ID="7"
VERSION="7 (wheezy)"
ID=raspbian
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


Checking drivers

snd_soc_bcm2708_i2s enbaled in /etc/modules
snd_soc_bcm2708_i2s loaded
bcm2708_dmaengine enbaled in /etc/modules
bcm2708_dmaengine loaded
snd_soc_wm8804 enbaled in /etc/modules
snd_soc_wm8804 loaded
snd_soc_hifiberry_digi enbaled in /etc/modules
snd_soc_hifiberry_digi loaded
Sound cards
aplay: device_list:252: no soundcards found...
--2014-04-23 19:29:41-- http://www.hifiberry.com/files/sin1000_48khz.wav
Resolving www.hifiberry.com (www.hifiberry.com)... 91.250.114.49
Connecting to www.hifiberry.com (www.hifiberry.com)|91.250.114.49|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5760044 (5.5M) [audio/x-wav]
Saving to: `sin1000_48khz.wav'

100%[======================================================================================>] 5,760,044 254K/s in 26s

2014-04-23 19:30:06 (221 KB/s) - `sin1000_48khz.wav' saved [5760044/5760044]

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:682: audio open error: No such file or directory

Looks like the card is not recognized.
I also identified a kernel error message with dmesg :
[ 14.511618] snd-hifiberry-digi snd-hifiberry-digi.0: ASoC: CODEC wm8804.1-003b not registered
[ 14.529711] snd-hifiberry-digi snd-hifiberry-digi.0: snd_soc_register_card() failed: -517
[ 14.556239] platform snd-hifiberry-digi.0: Driver snd-hifiberry-digi requests probe deferral


The light is green on the Hifiberry Digi card and I tried with several PSU (up to 2.1A).

I now believe I have an hardware issue with the Digi card. Could you confirm ?

Thanks
Paul

2 comments

Please sign in to leave a comment.