0

New install of HifiBerry with no sound

Hello,

I have a RaspberryPi B rev1 (volumio 1.55 image) that I'm trying to use the DAC on. I have implemented the missing connector following this guide:
https://volumio.org/forum/#p2415

And then I ran a software upgrade/test following this guide:
https://www.hifiberry.com/hifiberry-dac-software/

It looks like the DAC drivers are loading but, there is no signal on the RCA jacks:
pi@volumio:~$ ./check-system.dac
Checking system

Linux volumio 4.1.4+ #808 PREEMPT Thu Aug 6 15:51:03 BST 2015 armv6l GNU/Linux
Kernel: 4.1.4+
PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
NAME="Raspbian GNU/Linux"
VERSION_ID="7"
VERSION="7 (wheezy)"
ID=raspbian
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


bcm2708_dmaengine module not loaded
module file /lib/modules/4.1.4+/kernel/drivers/dma/bcm2708-dmaengine.ko not found
Sound cards
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
Playing WAVE 'sin1000_48khz.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo


Does this output mean that the module has failed to load properly?

[ 0.000000] Initializing cgroup subsys cpuacct
[ 0.000000] Linux version 4.1.4+ (dc4@dc4-XPS13-9333) (gcc version 4.8.3 20140303 (prerelease) (crosstool-NG linaro-1.13.1+bzr2650 - Linaro GCC 2014.03) ) #808 PREEMPT Thu Aug 6 15:51:03 BST 2015
[ 0.000000] CPU: ARMv6-compatible processor [410fb767] revision 7 (ARMv7), cr=00c5387d
[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[ 0.000000] Machine model: Raspberry Pi Model B Rev 1
[ 0.000000] cma: Reserved 8 MiB at 0x0e800000
[ 0.000000] Memory policy: Data cache writeback
[ 0.000000] On node 0 totalpages: 61440
[ 0.000000] free_area_init_node: node 0, pgdat c088be84, node_mem_map ce5d7000
[ 0.000000] Normal zone: 540 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 61440 pages, LIFO batch:15
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 60900
[ 0.000000] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708.boardrev=0x2 bcm2708.serial=0xa59e8d91 smsc95xx.macaddr=B8:27:EB:9E:8D:91 bcm2708_fb.fbswap=1 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0xfa00000 vc_mem.mem_size=0x10000000 force_turbo=1 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p3 elevator=noop rootfstype=ext4 rootwait smsc95xx.turbo_mode=N
...
[ 1.551843] WARN::dwc_otg_hcd_init:1047: FIQ DMA bounce buffers: virt = 0xcec14000 dma = 0x4ec14000 len=9024
...
[ 5.952856] snd-hifiberry-dac sound: ASoC: CPU DAI (null) not registered
[ 6.154610] snd-hifiberry-dac sound: snd_soc_register_card() failed: -517
[ 6.312250] snd-hifiberry-dac sound: pcm5102a-hifi <-> 20203000.i2s mapping ok

Thanks,
Devan

10 comments

Please sign in to leave a comment.