0

DAC+ and RPi 2 bundle seemingly not working

Hi,

I've been having some issues setting up my RPi 2 and DAC+ bundle. The two were ordered as a bundle from pi-shop.ch, which included a case and power adapter as well.
The RPi 2 seems to function well, I had loaded Arch and Kodi onto it, as I had on my previous Pi. The issue however, started when trying to get the DAC+ to work.
I followed this thread (https://www.hifiberry.com/forums/topic/hifiberry-dac-on-arch-not-working/) very carefully to find out which modules needed to be loaded in order to make everything function. The output of lsmod from Daniel helped a lot in order to double check that all modules were loaded properly. Unfortunately aplay -l did not recognize any sound cards.
Next I tried removing the DAC+ and Pi from the case, it seemed the GPIO pins weren't bottoming out, as the spacers were too long. Out of the case this wasn't a problem anymore, but still no aplay -l and no LED lighting up on the DAC+.
I tried loading the pre-made raspbian distribution available on this site, no luck it seems to be only for the older armv6 Pi.
Next I tried some of the supported software, I chose Openelec, as this was closest to the intended use I had for the pi, namely Kodi. Following the instructions given on this site, still no aplay -l and still no LED lighting up on the DAC+.

So, I'm about at the end of my patience now. Is the DAC+ simply broken or is there something missing from the configuration/setup ? I made sure the distributions I was using were fully updated, I've been over the instructions available on this site many times, I've spent a long time searching through the web and have tried loading many different recommended combinations of modules in order to make this work.

6 comments

Please sign in to leave a comment.